Symptom
You want a standard a field to become editable. You go on the adaptation mode, deselect the Read-only box and apply the changes. After that, the field continues being Read-Only.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
- Go to the Customers work centre.
- Go to the Accounts view (it also happen in other views).
- Open ABC (being ABC the name of the contact).
- Click Adapt > Edit Master Layout.
- Hover over the field that you want to be editable.
- Click on Change Properties and deselect the option Read only.
- Click Apply.
- Click Edit.
Result: You cannot modify the field.
- Hover over the same field as before.
- Click Adapt > Edit Layout Changes.
- Click Change Properties.
Result: You can see that the box Read only is selected again.
Cause
Some fields are automatically Read only. This is our data model / BO model and is not KUT/Edit master layout related.
Resolution
You need to fill in the field the first time you deselected the Read-only box.
Steps:
- Surround the field that you want to be editable.
- Click on Change Properties and deselect the option Read only.
- Click Apply.
- Enter any value to the field.
- Save the changes in the Account.
Result: the field is now editable.
Keywords
read only, change properties, Edit layout changes, modify field, , KBA , LOD-CRM-ACC-PRI , Private Account (Customers) , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions