SAP Knowledge Base Article - Public

2594167 - Internal Pricing: Price Component Fields Are Greyed Out

Symptom

You are using Internal Pricing and want to manually add Price Components but the fields are greyed out.

Environment

SAP Cloud for Customer

Reproducing the Issue

Please note this can happen in other views, too, however, our example is the workcenter Contracts:

  1. Go to the Contracts work center.
  2. Go to the Contracts view.
  3. Open the relevant active contract.
  4. Go to the Items facet.
  5. Select any line item.
  6. Click the Pricing tab.
  7. Click add.
    RESULT: All fields in the Price Component pop-up are disabled

Cause

You need to maintain the necessary settings in your Business Configuration (BC). The price component is maintained in the pricing procedure. You need to configure the price strategy in your BC fine tuning.

Resolution

  1. Go to the Business Configuration work center.
  2. Select the relevant Implementation Project.
  3. Open the Activity List.
  4. Go to the Fine-Tuning tab.
  5. Search for Configure Price Strategy and open.
    You need to maintain the Price Component here.

See Also

Keywords

Contract, Price Component, Greyed out, not possible, Pricing, Opportunities , KBA , LOD-CRM-PRC , C4C Pricing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions