Symptom
- You are using internal pricing and want to manually add price components, but the fields are disabled.
Environment
- SAP Cloud for Customer
Reproducing the Issue
- Please note this can happen in other views, too; however, our example is the work center Contracts.
- Go to the Contracts work centre.
- Go to the Contracts work centre view.
- Open the relevant active contract.
- Go to the Items facet.
- Select any line item.
- Click the Pricing tab.
- Click add.
RESULT: All fields in the Price Component popup are disabled.
Cause
- You need to maintain the necessary settings in your Business Configuration (BC).
- The price component is maintained in the pricing procedure.
- You need to configure the price strategy in your BC fine-tuning.
Resolution
- Go to the Business Configuration work center.
- Select the relevant Implementation Project.
- Open the Activity List.
- Go to the Fine Tuning tab.
- Search for 'Configure Price Strategy' and open.
- Maintain the Price Component here to enable them in the transactions
See Also
Keywords
Contract, Price Component, disabled, not possible, Pricing, Opportunities, manual addition, SAP Cloud for Customer, configuration issue, pricing procedure, fine tuning , KBA , LOD-CRM-PRC , C4C Pricing , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions
SAP Knowledge Base Article - Public