Symptom
You are using Internal Pricing and want to manually add Price Components but the fields are greyed out.
Environment
SAP Cloud for Customer
Reproducing the Issue
Please note this can happen in other views, too, however, our example is the workcenter Contracts:
- Go to the Contracts work center.
- Go to the Contracts view.
- Open the relevant active contract.
- Go to the Items facet.
- Select any line item.
- Click the Pricing tab.
- Click add.
RESULT: All fields in the Price Component pop-up are disabled
Cause
You need to maintain the necessary settings in your Business Configuration (BC). The price component is maintained in the pricing procedure. You need to configure the price strategy in your BC fine tuning.
Resolution
- Go to the Business Configuration work center.
- Select the relevant Implementation Project.
- Open the Activity List.
- Go to the Fine-Tuning tab.
- Search for Configure Price Strategy and open.
You need to maintain the Price Component here.
See Also
- C4C Price List - is it integrated with Service Contract (The price component is maintained in the pricing procedure. You need to configure the price strategy in your BC fine tuning as described here).
- Add manual Price Component in C4C and then Request external price
- SAP Cloud for Sales Pricing
Keywords
Contract, Price Component, Greyed out, not possible, Pricing, Opportunities , KBA , LOD-CRM-PRC , C4C Pricing , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions