Symptom
You try to open a PDI developed OVS (Object Value Selection) pop-up for a specific field.
You may encounter two different scenarios:
- The OVS opens once, after closing it cannot be opened anymore.
- The OVS closes immediately without giving the user the possibility to choose a value.
Environment
SAP Cloud for Customer
Reproducing the Issue
Scenario 1:
-
Navigate to the UI where the custom OVS was embedded.
- Click on the custom OVS to select a value.
- Close the OVS pop-up.
- Try to open the OVS for a second time and you will realise that it does not react to the left mouse-click.
Scenario 2:
-
Navigate to the UI where the custom OVS was embedded.
- Click on the custom OVS to select a value.
- The pop-up is displayed but closes immediately.
Cause
This issue is occurring, as there is no list binding for the DefaultSet being used on the custom OVS.
Resolution
- Navigate to the OVS UI component via UI Designer/Cloud Application Studio (e.g. /YXXXXXX_MAIN/SRC/ProjectEntry/EmployeeSalesResp.OVS.uicomponent).
- Select the AdvanceListPane on the Properties tab.
- Open the menu for the Default Set mapping and move "DefaultSet1" to the bindings and maintain the properties there.
- Afterwards the OVS will work without any problems.
Keywords
c4c , cloud for customer, custom, ovs, pdi, pop-up, sdk, ui designer, pdi, solution, object value selection, open, close, DefaultSet, binding , KBA , pdi , c4c , pdi , sdk , custom , ui designer , cloud for customer , ovs , object value selection , pdi solution , pop-up , AP-RC-UIF-FLX , Page Layout & Key User Configuration , Problem
Product
SAP Cloud for Customer add-ins 1802 ; SAP Hybris Cloud for Customer add-ins 1711