SAP Knowledge Base Article - Public

2594656 - The Ticket Search with Customer Id Shows the Different Result, When Using Standard Search and Advance Search

Symptom

The Ticket search with customer id shows the different result, when using standard search and advance search.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Service work center.
  2. Go to the Tickets view and select All Tickets.
  3. In the standard search enter LMN (where LMN is the Customer Id).

You can see, the number of records/result of tickets shown are N (where N is number of tickets).

  1. Click on the Advance search option .
  2. In the advance search under field Customer Id, enter the value as LMN and click on Go button.

You can see, now the number of ticket results are M (where M is number of tickets, which is more than N ).

Cause

The standard search goes after multiple parameters and hence the result vary between that and advanced search.

Resolution

  1. Go to the Service work center.
  2. Go to the Tickets view and select All Tickets.
  3. In the column name Customer Id, click on the filter option and search with customer id LMN.

You can see it will show same result with M - number of tickets, as shown using advance search.

Keywords

Tickets, Standard Search , Advance Search , Column name Customer ID , KBA , ticket search with customer id , standard search and advance search , filter with column name , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions