SAP Knowledge Base Article - Public

2594681 - Exception: Missing Receipt or Return Document

Symptom

Intercompany Supplier Invoices may have this exception though there is a Goods and Service Receipt or an Inbound delivery existing.

"The goods receipt/return has not been posted yet"

"The receipt document is missing or invalid"

Environment

SAP Business ByDesign

Reproducing the Issue

1. Go to Supplier Invoice work center.
2. Go to Invoices and Credit Memos view.
3. Search for Respective Supplier Invoice.
4. Go to Exceptions tab.

The Exception message will be displayed

5. Go to Items tab.
6. Navigate to cost distribution Tab.

The system will display two entries: one with a reference item but no quantity, and the other with no reference item but having a quantity.

Cause

In any Intercompany scenario (where Purchase order has created a sales order automatically),  we expect that delivery received from sales order has to be the reference for the inbound delivery created. Thus we expect " Delivery notification ID" field in inbound delivery same as outbound delivery ID that was created for the Sales order.

When creating Inbound deliveries or GSR manually, accuracy is essential to prevent the expected appearance of this exception. This guideline applies to any scenario involving Intercompany transactions. For example:

  1. Sales Order -> Purchase Order ->Sales Order.
  2. Purchase Order ->Sales Order ->Purchase Order.
  3. Sales Order -> Purchase Order ->Sales Order ->Purchase Order.
  4. Purchase Order->Sales Order->Purchase Order->Sales Order.

Resolution

For the existing effected Supplier invoices:

  1. Go to items tab.
  2. Go to cost and distribution tab.
  3. Ensure that quantity exists against the Inbound delivery ID under reference Item column.

or

  1. Click on Add open items button.
  2. Click on check button.
  3. Ensure that quantity exists against the Inbound delivery ID under reference Item column.

Remove any empty rows that lack quantity or a reference item as they are considered missing.

To avoid this issue in future while creating Inbound delivery or GSR manually:

>>While creating manual Inbound delivery or Third party inbound delivery for the PO, ensure to enter value in "Delivery notification ID" field same as outbound delivery ID that was created for the Sales Order.

Keywords

Intercompany invoices, exception, Cost distribution, Quantity zero, Inbound delivery

, KBA , AP-SIP-SIV , Supplier Invoice , Problem

Product

SAP Business ByDesign all versions