SAP Knowledge Base Article - Public

2594940 - Form Custom Field does not appear as a Filter in Ad hoc Report - Performance Management

Symptom

A new custom field has been configured in the form template. When you run a report and add a filter using the custom field name, the custom field is not available in the selection.

Environment

SAP SuccessFactors Performance Management

Reproducing the Issue

  1. Add a custom element of any type in your PM template via Admin Center.
  2. Creare an Ad-hoc report and select the template in the Data Sets.
  3. In the Filters tab, select Refine Criteria.
  4. Select the field "Section Custom Field Name" or other custom field column.
  5. In By My Selection or By Rule tabs, the custom field is not available in the list.

Cause

In the Ad hoc reporting filters, the system lists down all the custom fields coming from all exisiting forms that were launched regardless of the template selected in the Data Sets. If no form is launched yet for the template where the custom field is added, the filter will not be able to pull this custom field in the report filter.

Resolution

The filter will only be able to include the custom field from the report filter list when a form is already launched for the template where you added the custom element.

In order to see the new custom field in the Filters list, please launch a new form for that template.

Keywords

custom field, ad hoc filter, custom field filter, report filter, form custom element , KBA , LOD-SF-PM-REP , Reporting & Analytics, Data Imports & Exports , LOD-SF-ANA-ADH , Adhoc Reports & Report Builder , Problem

Product

SAP SuccessFactors HCM Core all versions