Symptom
Unable to add Maternity Leave absence for any employee. Error displayed: System error. Contact system administrator
Environment
Employee Central – Time Off : Leave of Absence
Reproducing the Issue
- Navigate to Administer Time for any Employee
- Choose New Absence
- Select Time Type 'Maternity Leave'
- Enter all mandatory information
- Upon submission, error displays: System error. Contact system administrator
Cause
The cause of this error relates to the 'Right to Return' feature when a processing the Position Management Decision rule that is triggered upon submission of the absence.
This rule is located in the 'Right to Return' tab in 'Position Management'.
- Take Action > Make Correction on the rule and expand the Parameters being used.
- You will find that the code for the Decision Parameter does not equal exactly 'Decision' like is required by the rule engine.
Resolution
- To resolve you will need to create a new rule and when entering the code for the Decision parameter, enter exactly: Decision
Keywords
System error, Contact system administrator, Maternity Leave, Time Type, New Absence, Position Management, Decision , KBA , LOD-SF-EC-TIM , Time Off , LOD-SF-EC , Employee Central , LOD-SF-EC-RUL , DO NOT USE - Business Rules & Event Derivation , Problem