SAP Knowledge Base Article - Public

2595084 - Fields Are Greyed Out When Creating a New Contact

Symptom

When creating a new Contact fields such as E-mail,Phone,Fax,Mobile are greyed out.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Customers work center.
  2. Go to Contacts view.
  3. Click on New to create a new Contact.

Here if you have not selected any Account the fields such as E-mail,Phone,Fax,Mobile will be greyed out.

Cause

Once you select an Account these fields will be editable.

In C4C a Contact can be associated with multiple Accounts and every Account Contact relationship will have its own communication details maintained.

To create or edit Personal addresses for the Contact, choose the Addresses facet in Contact.

Resolution

This is the expected system behavior.

Keywords

Contact , read only, Customers , KBA , contact , e-mail address , phone , fax , account , LOD-CRM-CON , Contact , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions