SAP Knowledge Base Article - Public

2595225 - Any Added Item Gets Defaulted to the Wrong Item Type When Resorting to Quantity Contract in your Service Contracts

Symptom

You cannot change the defaulted Item type of the Item you added in a Service Contract, even though you configured additional Custom Item types.

Environment

SAP HYBRIS CLOUD FOR CUSTOMER

Reproducing the Issue

Prerequites:

You scoped Quantity Contracts and also maintained additional Item Types of base Type Entitled Product – Contract Item in your Business Configuration.

  1. Go to the Contracts workcenter.
  2. Go to the Contracts view.
  3. Open any Contract.
  4. Go to Products.
  5. Click Add.
  6. Select ABC (ABC represents any Product concerned by the Quantity Contract).

Result : The item type is automatically filled with the wrong Item Type and cannot be updated.

Cause

For technical reasons, it is not possible to switch between item types with base type SCIT - Entitlement – Contract Item and base type SCEP - Entitled Product – Contract Item.

Resolution

You can add the item type in the Add popup, then you may get the warning 'Type Entitlement – Contract Item of product <product ID> does not match with type Entitled Product – Contract Item.' yet you can still proceed.

OR

You may maintain the Item Type Determination Rules, using the key fields which fits the best to your business; this might for example be the Product Category.

Keywords

Quantity Contracts, Service Contract. , KBA , LOD-LE-COP-SRV , Service Contract , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions