Symptom
You noticed that Gmail option is grayed out in E-Mail Integration work center, under User Settings and the end users are not being able to add Gmail as Mail server to enable Synchronization, as shown below:
Environment
SAP Hybris Cloud for Customer 1711 and higher.
Reproducing the Issue
-
Go to E-Mail Integration work center;
- Click User Settings;
- See that Gmail option is grayed out.
Cause
The Default Profile Template has been set to "Microsoft Exchange Direct Logon", as shown below:
Resolution
Log in as a System Administrator and Create a new Organization with Mailbox Access Type as "Google Direct Logon" and assign it to the respective users.
Creating a New Organization:
- Go to E-Mail Integration work center;
- Click Groupware Settings;
- Navigate to Organizations tab;
- Create a new Organization setting "Mailbox Access Type" as "Google Direct Logon".
Assigning the Mailbox Access Type to the affected users:
- Under Groupware Settings, navigate to tab Users;
- Find the affected users;
- Click pencil icon under Actions column to change the Organization for the affected users to the newly created Organization for Gmail and save.
Keywords
Invisible Solution, Gmail Server-Side Integration, Gmail, Grayed Out, Incorrect Account Logon , KBA , LOD-CRM-GW-SRV , Server side groupware intergration , LOD-CRM-GW-GM , Gmail , Problem