SAP Knowledge Base Article - Public

2595691 - Gmail Server-Side Integration: Gmail Option is Grayed Out in Application

Symptom

You noticed that Gmail option is grayed out in E-Mail Integration work center, under User Settings and the end users are not being able to add Gmail as Mail server to enable Synchronization, as shown below:

Gmail.jpg

Environment

SAP Hybris Cloud for Customer 1711 and higher.

Reproducing the Issue

  1. Go to E-Mail Integration work center;
  2. Click User Settings;
  3. See that Gmail option is grayed out.

Cause

The Default Profile Template has been set to "Microsoft Exchange Direct Logon", as shown below:

Default2.jpg

Resolution

Log in as a System Administrator and Create a new Organization with Mailbox Access Type as "Google Direct Logon" and assign it to the respective users.

Creating a New Organization:

  1. Go to E-Mail Integration work center;
  2. Click Groupware Settings;
  3. Navigate to Organizations tab;
  4. Create a new Organization setting "Mailbox Access Type" as "Google Direct Logon".

Assigning the Mailbox Access Type to the affected users:

  1. Under Groupware Settings, navigate to tab Users;
  2. Find the affected users;
  3. Click pencil icon under Actions column to change the Organization for the affected users to the newly created Organization for Gmail and save.

Keywords

Invisible Solution, Gmail Server-Side Integration, Gmail, Grayed Out, Incorrect Account Logon , KBA , LOD-CRM-GW-SRV , Server side groupware intergration , LOD-CRM-GW-GM , Gmail , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions