SAP Knowledge Base Article - Public

2595691 - Gmail Server-Side Integration: Gmail Option is Grayed Out in Application

Symptom

You noticed that Gmail option is grayed out in E-Mail Integration work center, under User Settings and the end users are not being able to add Gmail as Mail server to enable Synchronization, as shown below:

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

Gmail.jpg

Environment

SAP Hybris Cloud for Customer 1711 and higher.

Reproducing the Issue

  1. Open the E-Mail Integration work center.
  2. Select User Settings.
  3. Notice that the Gmail option is disabled.

Cause

The Default Profile Template has been set to "Microsoft Exchange Direct Logon", as shown below:

Default2.jpg

Resolution

Log in as a System Administrator and set up a new Organization with the Mailbox Access Type set to "Google Direct Logon." Assign this Organization to the relevant users.

To create a new Organization:

  1. Navigate to the E-Mail Integration work center.
  2. Select Groupware Settings.
  3. Go to the Organizations tab.
  4. Create a new Organization and choose "Google Direct Logon" for the Mailbox Access Type.

To assign the Mailbox Access Type to users:

  1. In Groupware Settings, open the Users tab.
  2. Find the affected users.
  3. Edit their Organization by clicking the pencil icon in the Actions column, select the new Gmail Organization, and save your changes.

Keywords

Invisible Solution, Gmail Server-Side Integration, Gmail, Grayed Out, Incorrect Account Logon , KBA , LOD-CRM-GW-SRV , Server side groupware intergration , LOD-CRM-GW-GM , Gmail , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions