SAP Knowledge Base Article - Public

2596089 - Contact Details Are Not Displayed In The Opportunities Contacts Facet

Symptom

You have added a contact in an opportunity in the Contacts facet. The contact information for the fields Function, Department, Phone, E-Mail, and so on, are not displayed in the table, even though the information is maintained in the contact.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center.
  2. Go to the Opportunities view.
  3. Open the opportunity ABC (ABC represents the opportunity ID).
  4. Go to the Contacts facet.
  5. Click Add.
  6. In the field Name select the contact XYZ (XYZ represents the contact ID).
  7. Click Save.
  8. The mentioned information is not displayed in the Contacts table.

Cause

The contact XYZ is not maintained in the opportunity's account.

Resolution

If you add a contact which does not belong to the account of the opportunity, then the details of the contact will be empty in the opportunity, as the address information depends of what is maintained in the account.

The contact needs to be maintained in the opportunity's account.

In case of Individual Customers, as they don't have Contacts that can be maintained, no details will be displayed when adding Contacts to the Opportunity.

Keywords

Contacts, Details, Opportunities, Account, Function, Phone, E-Mail, Department , KBA , LOD-CRM-OPP , Opportunity Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions