Symptom
You have added a contact in an opportunity in the Contacts facet. The contact information for the fields Function, Department, Phone, E-Mail, and so on, are not displayed in the table, even though the information is maintained in the contact.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Sales work center.
- Go to the Opportunities view.
- Open the opportunity ABC (ABC represents the opportunity ID).
- Go to the Contacts facet.
- Click Add.
- In the field Name select the contact XYZ (XYZ represents the contact ID).
- Click Save.
- The mentioned information is not displayed in the Contacts table.
Cause
The contact XYZ is not maintained in the opportunity's account.
Resolution
If you add a contact which does not belong to the account of the opportunity, then the details of the contact will be empty in the opportunity, as the address information depends of what is maintained in the account.
The contact needs to be maintained in the opportunity's account.
In case of Individual Customers, as they don't have Contacts that can be maintained, no details will be displayed when adding Contacts to the Opportunity.
Keywords
Contacts, Details, Opportunities, Account, Function, Phone, E-Mail, Department , KBA , LOD-CRM-OPP , Opportunity Management , How To