Symptom
Clients' instances may experience issues where candidates will not receive disqualifying emails (but only when these emails are set to be sent with a delay in Admin Center > Manage Recruiting Settings > Return Email Address Information).
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Have a delay set to disqualifying emails sent to candidates (Admin Center > Manage Recruiting Settings > Return Email Address Information);
- Either automatically or manually, move a candidate to a disqualifying status (e.g.: "Requisition Closed", "Not Qualified", "Unsuccessful");
- The email will not be sent to the candidate after the specified number of hours. This can also be chacked in the applicant's correspondent section.
Cause
There is a chance the delayed emails are no longer being sent because the Candidate Status Mail Delay quartz job stopped running. This can be checked in Provisioning > Monitor Jobs > Candidate Status Mail Delay.
Resolution
- Go to Admin Center > Manage Recruiting Settings > Return Email Address Information;
- Clear the information on fields "Job Owner", "Don't send emails older than (in days)" and "Delay Emails to Disqualified Candidates (in hours)";
- Unflag the box beside "Delay Emails to Disqualified Candidates (in hours)"
- Save changes;
- Re-add all the information to all the just cleared fields and re-check the just unchecked box;
- Save changes again. After that, you will see the jobs will start running once again.
Keywords
Candidate Status Mail Delay, Return Email Address Information,Delay Emails,Disqualified , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem