Symptom
- Clicking Reset User Password from Action Search Bar result, it redirects to a blank or empty page with only the show information link.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SuccessFactors HXM Suite
Reproducing the Issue
- Login to customer's Instance
- Search for Reset User Password
- Click on Reset User Password
You will be re-directed to an empty page with only the Show Version Information link.
Cause
The Data Model configuration is incorrect.
Resolution
- Export the Succession Data Model from Provisioning
- Check for the configuration mistake.
One identified mistake was "standard-element-ref" used without "standard-element id=" definition
For example: custom01 is used in the custom-filters, however it is not defined anywhere in the Data model (missing "standard-element id="custom01" " )
<custom-filters>
<filter-module id="default">
<standard-element-ref refid="custom01"/>
<standard-element-ref refid="custom02"/>
<standard-element-ref refid="custom03"/>
</filter-module>
</custom-filters> - Correct the mistake, for example removing "<standard-element-ref refid="custom01"/>" from the custom filter OR else define a standard element for custom01 like below
<standard-element id="custom01" max-length="255" required="false" matrix-filter="false">
<label>Customizable Field 2</label>
<label xml:lang="en-US">custom01</label>
<label xml:lang="de-DE">custom01</label>
<label xml:lang="fr-FR">custom01</label>
</standard-element>
Note: Access to provisioning is needed for the above (you might need to contact your Partner/Consultant)
Keywords
user password reset, error, empty page, data model, standard element , KBA , LOD-SF-PLT-UM , User Management , Problem