SAP Knowledge Base Article - Public

2596404 - Unable to use User password reset option

Symptom

  •  clicking on user password reset in admin center bring a blank page or empty page with only the show information link
    issue_reset_password.jpg
  • User password Reset is not working

Environment

  • SuccessFactors HCM Suite
  • BizX Platform

Reproducing the Issue

  1. Login as an admin 
  2. Go to Admin Centre
  3. Click on User Password Reset
  4. See you are re-directed to an empty page with only the Show version information link

Cause

One cause is the data model configuration is not correct

Resolution

  1. Export the succession data model from provisioning
  2. Check for configuratipn mistake
  3. One mistake could be "standard-element-ref" used without "standard-element id=" definition
    For example custom01 is used in the custom-filters, however it is not defined anywhere in the Data model (missing "standard-element id="custom01" " )

    <custom-filters>
    <filter-module id="default">
    <standard-element-ref refid="custom01"/>
    <standard-element-ref refid="custom02"/>
    <standard-element-ref refid="custom03"/>
    </filter-module>
    </custom-filters>
  4. Correct the mistake, for example removing "<standard-element-ref refid="custom01"/>" from the custom filter OR else define a standard element for custom01 like below

    <standard-element id="custom01" max-length="255" required="false" matrix-filter="false">
    <label>Customizable Field 2</label>
    <label xml:lang="en-US">custom01</label>
    <label xml:lang="de-DE">custom01</label>
    <label xml:lang="fr-FR">custom01</label>
    </standard-element>

Note: Access to provisioning is needed for the above (you might need to contact your Partner/Consultant)

Keywords

user password reset, error, empty page, data model, standard element , KBA , LOD-SF-PLT-UM , User Management , Problem

Product

SAP SuccessFactors HXM Suite all versions