Symptom
Once an Activity has been set to status Cancelled, fields are no longer editable.
Environment
SAP Hybris Cloud for Customer.
Reproducing the Issue
-
Go to the Activities center.
- Open the Appointments view.
- Open the Appointment ABC (ABC represents the Appointment ID).
- Select the Actions button and select Set as Cancelled.
- Now select the Edit button.
- The fields in the Appointment header can no longer be modified.
Please note that this behaviour is not specific to Appointments but also includes Tasks and Phone Call Activities also.
Cause
Once an Activity has been set as Cancelled, the fields can no longer be modified.
Resolution
This is the expected system behaviour.
Keywords
Activities, Appointments, Edit, Phone Call, set as Cancelled, fields , KBA , LOD-CRM-ACT , Activities , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions