SAP Knowledge Base Article - Public

2596757 - You Are Not Able to Close Ticket

Symptom

When you try to close a ticket, you receive the error message 'Send a reply to the requester before setting ticket XXX to status Completed.' (XXX represents the Ticket ID), and the ticket is not closed.

Environment

SAP Cloud for Customer core applications

Reproducing the Issue

  1. Go to the Service work center.
  2. Go to the Tickets view.
  3. Open ticket ID XXX. ( XXX represents the Ticket ID)
  4. Click on Edit and change the Status to Completed.
  5. Error message is shown 'Send a reply to the requester before setting ticket XXX to status Completed.'

Cause

The current status of the ticket has Assignment Status equal to Planner Action and, currently the system will not allow you to change the Assignment Status from Planner Action to Requester Action directly. This is the system expected behavior.

To check this you can:

  1. Go to the Business Configuration work center.
  2. Go to the Implementation Projects view.
  3. Select the current project and click on Open Activity List.
  4. On the Fine-Tune tab, search for Tickets for Customer Support.
  5. Open it and click on Maintain Status Schema.
  6. Here you can see to which Assignment Status each of the Status are linked.

Resolution

You can change the status to Processor action first and then change status to completed.

  1. Go to the Service work center.
  2. Go to the Tickets view.
  3. Open ticket ID XXX.
  4. Click on Edit and change the Status to In Process (any status with assignment status equal to Processor Action will work here).
  5. Save.
  6. Click on Edit and change the Status to Completed.

If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available.

Keywords

Ticket ; Status ; Status Schema ; Close ; Completed ; In Process ; Error , KBA , LOD-CRM-SRP , Service Request Processing , LOD-LE-CSM-SVL , Service Level Objective , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions