SAP Knowledge Base Article - Public

2596757 - You Are Not Able to Close Ticket

Symptom

When you try to close a ticket, you receive the warning message 'Send a reply to the requester before setting ticket XXX to status Completed.' (XXX represents the Ticket ID), and the ticket is not closed.

Environment

SAP Hybris Cloud for Customer 1711/05

Reproducing the Issue

  1. Go to the Service work center.
  2. Go to the Tickets view.
  3. Open ticket ID XXX.
  4. Click on Edit and change the Status to Completed.
  5. Warning message is shown 'Send a reply to the requester before setting ticket XXX to status Completed.'

Cause

The current status of the ticket is Requires Work. This status has Assignment Status equal to Planner Action and, currently, the system will not allow you to change the Assignment Status from Planner Action to Requester Action.

To check this you can:

  1. Go to the Business Configuration work center.
  2. Go to the Implementation Projects view.
  3. Select the current project and click on Open Activity List.
  4. On the Fine-Tune tab, search for Tickets for Customer Support.
  5. Open it and click on Maintain Status Schema.
  6. Here you can see to which Assignment Status each of the Status are linked.

Resolution

  1. Go to the Service work center.
  2. Go to the Tickets view.
  3. Open ticket ID XXX.
  4. Click on Edit and change the Status to In Process (any status with assignment status equal to Processor Action will work here).
  5. Save.
  6. Click on Edit and change the Status to Completed.

This is the system expected behavior. The system does not allow the change of assignment status from planner action to requester action.

If you need this functionality urgently you may contact your implementation manager.

You can find more details about the services offered by Cloud Service Center on https://www.sap.com/services/application-development.html . You can contact Cloud Service Center as follows:

  1. If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder
  2. If you are a customer: please use the little blue box “Contact Us” shown on the very right hand side of https://www.sap.com/services/application-development.html, choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page

Keywords

Ticket ; Status ; Status Schema ; Close ; Completed ; In Process , KBA , LOD-CRM-SRP , Service Request Processing , LOD-LE-CSM-SVL , Service Level Objective , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions