Symptom
You are reporting on Opportunity Header data source, and when including Main Contact E-Mail field in the report results, you notice it brings # (not assigned) value. In the contact information screen, however, you see the e-mail is maintained for this contact.
Environment
SAP Sales Cloud
Reproducing the Issue
-
Run a report based on Opportunity Header data source.
- Include the field E-Mail (Main Contact) in the report results.
- Notice this field brings "#" (not assigned) result only.
Cause
Opportunity Header, as well as similar data sources, retrieve the Main Contact E-Mail information from the following master data:
Workcenter Customers > Accounts > Contact > Addresses > Personal Addresses.
Your contact does not have the e-mail information maintained at this level, which explains this behavior. Your contact data are likely maintained in Contact Overview section instead.
Resolution
If you want to have the information from Contact Overview displayed in your reports, you can data source Account Contact Data [BPCSCONTB], which is the DS designed to bring specific information about Accounts.
Keywords
data source, email address, e-mail, fax, contact, report , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , LOD-CRM-OPP , Opportunity Management , How To