SAP Knowledge Base Article - Public

2597087 - Functionality of Single Sender and return address - Recruiting Management

Symptom

  • Customer is sending offer approvals to the candidate via take action → offer → offer letter.
  • The email that the candidate received is coming from the email address defined in the Single Sender in provisioning.
  • After clicking 'reply' to that received email, it changes to the return email address configured in Admin Center → Manage Recruiting Settings.

The Single Sender feature changes introduced as part of the 2H 2024 have been rolled out and are no longer available in Preview and Production.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental"

Environment

SAP SuccessFactors Recruiting Management

Cause

  • The switch defined in the Admin Center → Manage Recruiting Settings "Make return email address editable in 'Email Candidate'" should be honoured for system triggered emails only.
  • The Offer Letter is manually triggered hence the feature "Make return email address editable in 'Email Candidate'" should not be applicable for a manually triggered event.

Resolution

The functionality of the Single Sender and return address (depending on if Message Center is enabled or not):

  • For Adhoc emails
  1. If Single Sender is OFF

    The ‘From’ email address always system@successfactors.com
    The ‘From’ name could be the sender’s name.
    The ‘Reply’ address is the sender’s email address
    The ‘Reply’ name is the sender’s name

  2. If Single Sender is ON

    - If Return Email Address Information (in Manage Recruiting Settings) is defined

    The ‘From’ and the return email address is the sender’s (operator) address and name.
    The ‘Reply’ name is the sender’s name.

    - If Return Email Address Information (in Manage Recruiting Settings) is NOT defined

    The ‘From’ and return email address is the Single Sender's email address and name.
    The ‘Reply’ name is the Single Sender’s name.

Please see below the logic depending on Message Center being enabled or not:

  1. From <email address> will have following values based on single sender switch and other parameters:
    1. Single sender is enabled:
      1. correspondence<company Id>@<james server domain>
      2. Example: if <company id> is SAP. And <james server domain> is pc4james.com
        1. correspondenceSAP@pc4james.com
    2. Single sender is disabled:
      1. If "sf.systemMail" property is configured at server level, then the value of property will be email address
      2. If "sf.systemMail" property is not configured, then email address will be system@successfactors.com
  • For all other emails
  1. If Single Sender is OFF

    The ‘From’ email address always system@successfactors.com.
    The ‘From’ name could be the sender’s name.
    The ‘Reply’ address as defined in the Manage Recruiting Settings.
    The ‘Reply’ name as defined in the Manage Recruiting Settings.

  2. If Single Sender is ON

    - If Return Email Address Information (in Manage Recruiting Settings) is configured and enabled (meaning that the checkbox is ticked and there is an email address and a display name): 

    The ‘From’ email address is the address in Manage Recruiting Settings.
    The ‘From’ name could be the name in Manage Recruiting Settings.
    The ‘Reply’ address as defined in Manage Recruiting Settings.
    The ‘Reply’ name as defined in Manage Recruiting Settings.

    - If Return Email Address Information (in Manage Recruiting Settings) is NOT configured, nor enabled (meaning that the checkbox is NOT ticked and there is NO email address NOR display name, both fields are empty): : 

    The ‘From’ email address is the customer defined Single Sender address.
    The ‘From’ name could be the Single sender’s name.
    The ‘Reply’ address as defined in the Single Sender address.
    The ‘Reply’ name as defined in the Single Sender address.
  • Offer Letters
  1. If Single Sender is ON
    If Return Email Address Information (in Manage Recruiting Settings) is defined

    The ‘From’ shows the Single Sender's email address and name. 
    The ‘Reply’ is the Single Sender's email address and name.
  • The behavior for Offer Letters is an expected behavior.

Possible issue using the Single Sender feature: many times the email might be undelivered because it would be treated as spam by email clients like Gmail, Yahoo, etc. as the actual sender (system@successfactors.com) doesn't match the one defined by Single Sender feature (user@domain.com).

NOTE: There is particular behaviour of the Single Sender feature in relation to the "Email Job to Friend" and "Refer Friend to Job" email triggers. Please see KBA's below in the "See Also" section.

See Also

Keywords

single, sender, name, email, return address, information, manage, recruiting, settings , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem

Product

SAP SuccessFactors Recruiting all versions