Symptom
- 'Assigned By' field is not visible in the user's learning plan.
- todoFields[assignedBy].visible property is set to true in USER LEARNING PLAN configuration.
- Users do not see 'Assigned by' field for the administrators' assigned items and curricula.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
Note: todoFields[assignedBy].visible is set to true in USER LEARNING PLAN configuration (System admin > Configuration > System Configuration > USER LEARNING PLAN).
As an administrator:
- Login as Admin >
- Assign item to user >
- Navigate to user record >
- Launch Proxy >
- Search for the assigned item in learning plan >
- Notice that 'Assigned by' field does not show the administrator ID.
As a learner:
- Login as User >
- Navigate to My Learning Plan >
- 'Assigned by' field is not found under Item title.
Cause
- This behavior is by design.
- The 'Assigned by' field will only be available if the item or curriculum is self assigned or is assigned by a manager.
- The 'Admin details' will not be shown.
Resolution
An enhancement request can be submitted to have this functionality considered in the future development cycles. Please submit a request via the Customer Community Portal and, for detailed steps, review KBA 2090228 - How to submit enhancement requests for SAP SuccessFactors products.
See Also
2090228 - How to submit enhancement requests for SAP SuccessFactors products.
Keywords
SF, LMS, todoFields[assignedBy].visible, User, Learning, Plan, todoFields, set, true, item, admin, curricula, system, configuration, enhancement, request, self, assigned , KBA , LOD-SF-LMS-ADM , System Admin, Global Variables, References , LOD-SF-LMS , Learning Management System , Problem