SAP Knowledge Base Article - Public

2598445 - Marketing Attribute Cannot be Added to Account

Symptom

You want to assign a Marketing Attribute to an account, but the Add button is not available.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work center.
  2. Select the Accounts or Contacts work center view.
  3. Open an account or a contact.
  4. Navigate to the Marketing Attributes facet.

No Add button is available in the upper right corner.

Cause

You have added one or more Business Action Restrictions to the Business Role which is assigned to the affected Business User. The Business Action Restrictions with the names BUSINESS_ATTRIBUTE_ASGNM_READ and BUSINESS_ATTRIBUTE_ASGNM_ADD are responsible for the missing Add button.

Resolution

  1. Go to Administrator work center.
  2. Select Business Roles work center view.
  3. Search for the Business Role which is assigned to affected Business User.
  4. Highlight Business Role and click on Edit.
  5. Navigate to Fields & Actions facet
  6. Scroll down to Business Action Restrictions

 Remove Business Action Restrictions BUSINESS_ATTRIBUTE_ASGNM_READ and BUSINESS_ATTRIBUTE_ASGNM_ADD from the list.

Keywords

Marketing Attribute, Account, BUSINESS_ATTRIBUTE_ASGNM_ADD, BUSINESS_ATTRIBUTE_ASGNM_READ, Business Role , KBA , LOD-CRM-ACC , Account , LOD-CRM-MKT-CAM , Campaigns , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions