Symptom
Notification alert is not being triggered twice for the same object.
Environment
SAP Cloud for Customer
Reproducing the Issue
Pre-requisites:
You have already created a workflow rule, which should trigger a notification on every save of the object to be modified.
We will use Tickets as example.
- Go to the Service work centre.
- Select the Tickets view.
- Open a ticket.
- Make a dummy change.
- Click the Save button.
You can see that the notification is triggered and the red circle appears on the Notifications icon.
- Make another dummy change.
- Click the Save button again.
- Click on the Notifications icon.
You can see that the notification has been triggered, but not the notification alert (red circle).
Cause
This is the expected system behaviour.
Resolution
The notification alert is object specific. Once a notification is created for an object then it cannot be changed.
It is not possible to change the notification alert for the same object multiple times for which the notification alert is already generated.
Notifications shall be used to notify a user about certain activities in the system which need his attention and may require further actions from him.
The characteristic of the notification alert can be described as follows:
- Only I as the receiver of this notification instance.
- Reading the notification is expected.
- Action from the receiver is expected.
- Contains reference to the sender who triggered the notification.
- Contains reference to a single business object instance which triggers the notification.
Keywords
Notification, Red circle, Notification alert, count , KBA , notification , notification alert , red circle , AP-RC-UIF-RT , UI Framework Runtime , LOD-CRM-SRP , Service Request Processing , Problem