SAP Knowledge Base Article - Public

2599335 - Solution Locked by User SAP_SYSTEM. This Solution is Locked by Another Process

Symptom

You are trying to carry out a Lifecycle Management task on your custom solution (e.g. Assemble , Downlaod etc..), however you cannot as you receive the below errors:

  • Unable to lock ONE_OFF YXXXXXXX_, it is locked by user SAP_SYSTEM.
  • This solution is locked by another process.
  • Try again later.

Environment

  • SAP Cloud for Customer
  • SAP Cloud Applications Studio

Reproducing the Issue

  1. Open the SDK.
  2. Open the affected solution.
  3. Open the Implementation Manager.
  4. Attempt to carry out the Lifecycle Management activity on your solution.
  5. Errors will appear in the log files.

Cause

If this solution is uploaded to multiple tenants that are within the one physical system, you can use the functionality called Automated Distribution.

This means that if you have uploaded your solution to one tenant on this physical system, the Automated Distribution will then automatically update the version of the solution on all tenants within the one physical system.

The user SAP_SYSTEM is an SAP technical user that is used for background jobs in the system. This user is used for the task of Automated Distribution, hence if you try to download or make changes to your solution while the Automated Distribution is being carried out, you will see this error as this is expected that the user SAP_SYSTEM is still carrying out the Automated Distribution task.

Resolution

When distributing solutions, failures may occur due to one of the following reasons. Below are the issues and solutions for each scenario:

1. Both Upload and Activation Failed

  • Issue: The solution was neither uploaded nor activated successfully.
  • Solution:

    1. Trigger a restart of the upload process.
    2. To do this, navigate to:
      • SAP Cloud Applications Studio.
      • Implementation Manager.
      • Tenant Status.
      • Click on Automated Distribution.
    3. Note: Both upload and activation will be automated once restarted.

2. Activation Failed Only

  • Issue: The solution was uploaded, but the activation was unsuccessful.
  • Solution:

    1. Log in to the relevant tenant.
    2. Manually activate the solution.

It's recommended to check the version history logs for the respective tenants to identify any additional issues or confirmation of successful distribution.

See Also

Please see section 6.6.2 'Implementation Manager Quick Guide' in the SAP Cloud Applications Studio Help Documentation.

Keywords

SAP_SYSTEM, Solution Locked, Another Process, SDK, PDI, Assemble, Download, Activate, Automated, Distribution , KBA , AP-RC-BDS-1O , ByDesign Studio OneOffs , How To

Product

SAP Cloud Applications Studio all versions