Symptom
You have an Invoice Run maintained in the system and expect all the invoice requests to be changed from To Be Invoiced to Released status. However, you feel that the invoice run is too slow and is taking too long to process.
Environment
SAP Business ByDesign
Reproducing the Issue
-
Go to the Customer Invoicing work-center.
- Go to the Invoice Requests view.
- Choose To Be Invoiced and click on Go.
- Thousands of invoices are in To Be Invoiced status.
Cause
The cause for the slow processing of the invoice requests is the following:
- There are hundreds or thousands of invoice requests with a large amount of invoice items.
- Some of the invoice requests will also have more than 50 line items and these will always take a longer time to process.
- The work package size of this run is currently set to 1000. Due to the large amount of invoices and some errors within the invoice creation the system is not able to complete the run and this is causing the issue. The system automatically schedules parallel work packages to speed up the processing time for a mass data run. With this value, you can reduce the maximum number of invoice requests per work package in case you get errors. The number needs to be between 50 and 1000.
Resolution
Split the invoice requests to smaller chunks and push them in the invoice run so that lesser invoice requests are pushed at once.
It also is advisable to create an invoice run that will run at regular intervals to prevent a large number of invoice requests all to be invoiced at once.
You also need to ensure that the invoice run is created with a Maximum Invoice Requests per Work Package of 50 and that the invoice created does not have more that 100 line items.
See Also
Keywords
Invoice Run, Slow, Invoice Requests, To Be Invoiced, RUN, takes to long, , KBA , AP-CI-RUN , Customer Invoice Run , Problem
SAP Knowledge Base Article - Public