Symptom
While viewing Payment Information on an Employee's Profile or in Payment Information history, some fields are missing despite being available while editing Payment Information.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
-
SAP SuccessFactors Employee Central
- Payment Information
- PP3
Reproducing the Issue
1. Navigate to the Employee Profile of a user and scroll down to Payment Information > Click 'Edit' > Note the fields available while in Edit mode > Save changes
2. After saving, scroll to the Payment Information portlet > Note that one or more of the fields available in Edit mode are not visible here
3. Click on Payment Information history > Note the fields are not visible here also
Cause
The visibility of these fields in the Payment Information Portlet Configuration User Interface are set to 'No'.
Resolution
In order to be able to view these fields in the Payment Information portlet and in the history page, you will need to set the visibility of these fields to 'Yes'. To do so;
1. Get the name of the Payment Information UI, this can be found by going to 'Manage Data > Search for 'Personal Information Screen Lookup' > The UI name is the 'screenid' field
2. Navigate to 'Manage Configuration UI' > Search for the UI
3. Hover your mouse over each of the fields that are missing > Click on 'Edit Properties'
4. Set the 'Visibilty' property from 'No' to 'Yes'
5. You will now be able to view the fields on Employee Profile and in Payment Information history
Keywords
Payment Information, Payment Information History, Fields, Hidden, Visibility, Payment Method, Pay Type, Bank Name, Currency, Bank Country, Account Type, IBAN, Account Owner, Account Number, BIC Code, Sort Code, Manage Configuration UI, Payment Information UI , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , LOD-SF-EC-PP3 , People Profile (PP3) , Problem