SAP Knowledge Base Article - Public

2600429 - Characteristic Response Option shows # in the Report Campaign Response Details (ID CODCAMPRO_Q0001)

Symptom

In the report Campaign Response Details the characteristic Response Option shows # and a value for some campaigns.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the Work Center Business Analytics or Analysis.
  2. Go to the View Design Reports or Reports.
  3. Search for the report Campaign Response Details (ID CODCAMPRO_Q0001).
  4. Open the report with the default view and selection.
  5. Click on Go.
  6. Add key figure Counter to the columns.
  7. Add characteristic Campaign and Response Option to the rows.
  8. You will see all the Response Options and some Campaigns will show # and a value for it.

Cause

In the report Campaign Response Details the numbers correspond to the particular response option associated with the responses in the particular Campaign.
Here, the # corresponds to the responses which do not have any response option associated with it.

Resolution

In a campaign the responses can be of various types. This can include activities such as phone calls, emails or tasks. Response types also include opportunities and leads. The responses corresponding to each response type could be seen by navigating to the corresponding Facets/Tab (Activities, Leads, Opportunities). If you do not see these Facets/Tabs, please go to the Adaptation Mode and add it to the screen.

As opportunities and leads are internal processes they do not have a response option. Activities are related with communication with the end user and as a result of this they can have response options. In this way you can count the number of values associated with # by navigating to each of this facet and looking for the responses without a response option.

Some of these statistics relating to the number of leads, opportunities, activities, etc. are also there in the Overview facet of each Campaign. And it is not necessary that all the activities would have a response option associated with it.

If you have no opportunity and no lead but still have values for #, please go to the Respondents tab and do a descending sort on the Last Response Option column. Here you can check, if you have entries with no last response. Please do not forget to check the values at the top for Without response.

See Also

For example:

In the report Campaign Response Details the Campaign ABC (ABC stands for the Campaign ID) shows 3 for # in the Response Option. Open the Campaign and go to the Opportunities facet. It has 3 opportunities hence 3 responses have no response options. Navigate to the Activity facet. All the phone call activities have a response option associated with it. So the 3 opportunities are the reason why the report shows value 3 for #.

In the report Campaign Response Details the Campaign XYZ (XYZ stands for the Campaign ID) shows 95 for # in the Response Option. Open the Campaign and go to the Opportunities, Leads and Activities facet. The campaign has 95 leads which do not have a response option. All the activities have a response option associated with it.

Keywords

response option, campaigns, CODCAMPRO_Q0001, #, report, campaign response details , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions