SAP Knowledge Base Article - Public

2600578 - National ID Portlet Display Multiple Rows

Symptom

During New Hire, the National ID (NID) Portlet opens with two rows whereas none is expected.
It is expected that when you click on "Add" only then, a row is revealed to create a NID record.

Environment

Employee Central - Hire / Rehire

Employee Central - Personal Information

Employee Central - National ID

Reproducing the Issue

  1. Proceed with hiring/rehiring an employee
  2. The portlet for NID displays multiple rows.

(please note that the below config varies depending on customers requirements

Example 1 - 1 row

1 rule added.jpg

Example 2- 2 rows

2 rules added.jpg

 There may be more rows.

Cause

This is cause by rule(s) set to trigger onInit on the NID portlet

Resolution

In Manage Business Configuration, Check review the behaviour of rule set to trigger onInit.

The system may be adding rows as defined in the rule.

If this is the case please remove any such rule and and the default display will be restored.

no rule.jpg

Keywords

National ID, Personal Information, Hire New, , KBA , LOD-SF-EC-HIR , Hire & Rehire Wizards , LOD-SF-EC-BCI , Manage Business Configuration (BCUI) & Data Models (XML) , LOD-SF-EC-PER , Person Data (All Person Data Types) , Problem

Product

SAP SuccessFactors Employee Central all versions