Symptom
Customer is getting the error below when trying to import holidays:
Holiday Date
The data format is mm/dd/yyy hh:mm:ss AM/PM. The time component is optional (ex. 01/15/2014 09:00:00 AM or 01/15/2014).
or
Holiday field should be in text format.
Environment
SuccessFactors Learning Management System (LMS)
Reproducing the Issue
1.) Learning Administration > System Admin > Tools > Import Data > Action: Add / Update / Add and update & Record Type: References
2.) Import failed
3.) When you download the error log, the comments would say that the formatting is not correct or the format should be in text.
Cause
The date not formatted correctly.
Resolution
1.) On the import file, ensure that the date format is mm/dd/yyyy. (January 01, 2018 should show as 01/01/2018 and not 1/1/2018)
2.) On the import file, ensure that the date is on text format. (Suggestion: use the formula on the date =TEXT(a1,"mm/dd/yyyy") where a1 is the original date on date format)
3.) Reupload the file (Learning Administration > System Admin > Tools > Import Data > Action: Add / Update / Add and update & Record Type: References). It should now import successfully
Keywords
referrence import, holiday import, holiday import error, error when importing holiday , KBA , LOD-SF-LMS-ADM , System Admin, Global Variables, References , Problem