SAP Knowledge Base Article - Public

2601459 - Apps Not Available Despite Having Correct Business Roles

Symptom

Some tiles that should be available on the Fiori Launchpad in SAP S/4HANA Cloud Public Edition are not displayed

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Add a business role to a user using the Maintain Business Users app
  2. Now log in as that user to view the apps that are available to them
  3. At this point not all tiles or catalogs may be available to the user

Cause

One cause of this issue would be if the business role has been altered, and is in the preparation status

Resolution

  1. Confirm that the app should really be available for this business role, using the IAM Information System app with a Key User to search for the role and app
  2. Once this is confirmed check the status of the business role using the Maintain Business Roles app
  3. If the status of the role is "In Preparation" , then the role will need to be activated to ensure that it will work as expected

Keywords

Maintain Business Users, Maintain Business Roles, IAM Information Status, In Preparation, Key User , KBA , BC-SRV-APS-IAM , Identity and Access Management , Problem

Product

SAP S/4HANA Cloud Public Edition all versions