Symptom
How to check certificate expiry date within SAP HANA Cloud Platform, after renewing certificate within SAP Analytics Cloud?
You renewed your certificate in SAP Analytics Cloud and you have problems using your Live Connections to SAP HANA in Cloud Platform: failed to connect to system.
Environment
- SAP Analytics Cloud
- SAP HANA in SAP Cloud Platform
Reproducing the Issue
- Renew certificate within SAP Analytics Cloud
- Update certificate within SAP Cloud Platform. Follow Step: Live Data Connection to SAPCP with SSO
- After updating, there is no way to check the expiry date for the certificate
Cause
The certificates are added to your HANA system but not removed unless you do it manually.
Resolution
1. Login to SAP HANA Cloud XS Admin Page and check if Trust Manager is enabled?
https://<Your_HANA_Server>:<HANA_PORT>/sap/hana/xs/admin/
2. If the Trust Manager is no enabled, add roles sap.hana.xs.admin.roles::TrustStoreAdministrator and sap.hana.xs.admin.roles::TrustStoreViewer
3. Once the roles are added/activated, Trust Manager will be enabled
4. Select the Trust Manager and check the expiry date on certificate
See Also
- How to find User Assistance for SAP Analytics Cloud?
- Ask a question on the SAP Community!
- 2487011 - What information do I need to provide when opening incidents with SAP Analytics Cloud (Hint: Use component LOD-ANA*)
Keywords
SAC, SAP BusinessObjects Cloud, Business Objects, SAC, renew, certificate, HCP, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics , KBA , LOD-ANA , SAP Analytics Cloud (SAC) , LOD-ANA-BI , Business Intelligence Functionality, Analytic Models , LOD-ANA-PL , Planning , LOD-ANA-BR , SAC Boardroom , LOD-ANA-PR , SAC Predictive , Problem