Symptom
You create or adjust a Customer Contract Renewal Rule, but the Line Items in a created Contract are not Renewed.
Environment
SAP Business ByDesign
Reproducing the Issue
-
Create a Rule in the Renewal and Cancellation for Customer Contract Fine-Tuning Activity.
- Check the box for Re-determine Price and Re-determine Price Date.
- Create a manual Contract from the Sales Order work center.
- Select the created Renewal Rule.
- Add an Item and manually change/add the Price List value.
- The items are not renewed as you have set up or the Price for the Items changes.
Cause
- The item level contains a provision date.
- When you activate Re-Determine Price and Re-Determine Price Date, the system will determine the price in the renewal task according the new price Date.
- During the determination the price needs to be maintained in a valid Price List for the new date.
- If Re-Determine Price Date is not checked, the pricing date will be taken over from the previous contract (header level).
- If you have no valid List Prices maintained, the renewal task will fail and the items will not be renewed.
This is the expected system behavior.
Resolution
You cannot use manual prices and Re-Determine Price and Re-Determine Price Date for Renewal Rules, if you have not maintained a valid Price List.
Please maintain a Price List for the position or change the Renewal Rule by deselecting Re-Determine Price and Re-Determine Price Date. To do so, follow these steps:
- Navigate to the Business Configuration Workcenter.
- Open the Renewal and Cancellation of Customer Contract Fine-Tuning Activity.
- Select the used renewal Rule.
- Uncheck the boxes for Re-Determine Price and Re-Determine Price Date.
Keywords
Customer Contract, Price, Change, Renewal, Task, Error, Fehler, Aufgabe, Erneuerung, Preis, Änderung, Vertrag , KBA , AP-CCP-CC , Customer Contract , Problem