SAP Knowledge Base Article - Public

2601640 - Surveys do Not Attach to Visits as Per Routing Rule.

Symptom

When creating a Visit, Surveys do not get attached as per Activity Plan and Routing Rule.

Environment

SAP Hybris Cloud for Customer.

Reproducing the Issue

Prerequisite: An Activity Plan and Routing Rule have been created to assign Surveys to any Visit that is created with an Account associated with the Taregt Group ABC (ABC represents the Target Group ID).

  1. Go to the Visits work center.
  2. Go to the Visits view.
  3. Select the New button.
  4. In the Account field, select Account DEF (DEF represents the Account ID). Please note Account DEF is associated with Target Group ABC.
  5. Select Save and Open
  6. Go to the Surveys tab.
  7. No Survey has been attached.
  8. Select the Actions button.
  9. Select Refresh Visit.
  10. An information message is triggered at the bottom of the Visit 'Activity Planner Routing Rules were re-executed' but still no Surveys are attached.

Cause

There has already been a Visit ID created for this Account where the Routing Rule has been successfully executed and the Surveys have been attached.

Resolution

It will be assigned only to the first Visit of an Account ID. This is the expected system behaviour.

Keywords

Surveys,  Visits, Activity Plan, Routing Rule , Activity Planner Routing Rules were re-executed , KBA , routing rule , activity planner routing rules were re-e , surveys , visits , activity plan , LOD-CRM-ACT-ROT , Activity Routing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions