SAP Knowledge Base Article - Public

2601879 - Address Field not Appearing in Emergency Contact Portlet

Symptom

I have configured the address field in the emergencyContactPrimary element in Manage Business Configration.

This field is not appearing during the hire wizard and does not appear when trying to add/edit a record in the emergency contact portlet.

Environment

Employee Central - Manage Business Configuration.

Employee Central - Emergency Contact Portlet.

Reproducing the Issue

1. Enable the address field under the emergencyContactPrimary element in Manage Business Configration.

address.png

2. In the add new employee wizard, look for the address field in the emergency contact portlet. It does not appear.

3. In an employee's profile, create or edit a record in the emergency contact portlet. Look for the address field. It does not appear.

Cause

The address field in the emergencyContactPrimary element is deprecated (being replaced/no longer in use) but it wasn't filtered out in the Manage Business Configuration tool.

The engineering team are working on filtering out the field in the Manage Business Configuration tool.

Resolution

Disable the address field by selecting enabled = no.

enabled.png

Keywords

Address, Address Field, Emergency Contact, Field Not Appearing, Primary Emergency Contact, BCUI, Manage Business Configuration, ECT-83958. , KBA , LOD-SF-EC-BCI , Manage Business Configuration (BCUI) & Data Models (XML) , Problem

Product

SAP SuccessFactors Employee Central 1611 ; SAP SuccessFactors Employee Central 1702 ; SAP SuccessFactors Employee Central 1705 ; SAP SuccessFactors Employee Central 1708 ; SAP SuccessFactors Employee Central 1711 ; SAP SuccessFactors Employee Central 1802