SAP Knowledge Base Article - Public

2601908 - External Candidate does not receive the forgot password e-mail notification from the career site - Recruiting Management

Symptom

External candidate does not receive a password reset email when trying to log in to their candidate profile

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Candidate accesses the career site but is unable to log into their profile.
  2. Candidate clicks on 'Forgot Password' link and enters their email address.
  3. No e-mail is received by the candidate.

forgot password.png

Cause

There are many possible causes:

  • The candidate had two candidate profiles in the system that were merged by the company admin, leading to confusion over their correct User System ID.
  • The candidate simply changed their contact email and attempts to use this new email in the reset password box.
  • The candidate profile has been anonymized (purged).
  • There is a misconfiguration in email notification settings.

Resolution

Explain how the customer can validate if the email been used is still valid and valid to an existing Candidate Profile:

  1. If the email doesn't exist:
    • The Candidate Profile could have been anonymized - It's not possible to validate if a Candidate Profile has already been anonymized.
    • The '' '' has been merged - It's not possible to validate if the Candidate Profile has been merged but you can notify the Candidate through the notifcation ..... (KBA for merge)
    • Candidate has chagned the email - 
      • External candidates should enter their Login User ID into the Forgot Password section. The forgot password notification will then be sent to the candidate's contact email.

        If the option "Use email as external applicant user ID" is enabled in provisioning, the Login User ID will be the email address used when creating the profile.

      • How can we find the Primary Email
  2. If the email exists:
      • There is a misconfiguration in email notification settings. EXAMPLE: Make sure to configure the email as explained in the Guide (Guide link)
      • Make sure the email configuration is properly set - 2087468 - Emails Blocked or Not Delivered Due to Spam Filters, Spoofing, Bombing (mass mail), IP Address Allowlists

How to submit the password reset request

External candidates should enter their Login User ID into the Forgot Password section. The forgot password notification will then be sent to the candidate's contact email.

If the option "Use email as external applicant user ID" is enabled in provisioning, the Login User ID will be the email address used when creating the profile.

This is the "Primary Email" which will never change, not necessarily their "Contact Email" address which can be changed at any time.

(For more information, see KBA 2157574 - Primary Email Address Versus Contact Email Address - Recruiting Management.)

How can we find the Primary Email

The Primary Email is displayed on the Candidate Profile page only if it is defined in the Candidate Profile Template.

(For more information, see KBA 2676324 - The primaryEmail Field Within the Candidate Profile - Recruiting Management.)

Admins can use the tool 'Manage Duplicate Candidates' to find the Primary Email and the Contact Email.

  1. Go to Admin Center > Manage Duplicate Candidates > Manually Merge Duplicate Candidates tab.
  2. Select 'External Candidate'.
  3. Select 'Contact Email'.
  4. Type the email address and search.
  5. If the candidate cannot be found, select 'Primary Email' and search again.

a. If the candidate profile is found, provide the Primary Email address to the candidate. After resetting the password successfully, the candidate needs to sign in using the Primary Email.

b. If the candidate has already used the correct primary email address to submit the password reset request, please refer to the KBAs 22966362146642 and 2087468 to review the email settings.

c. If the candidate profile cannot be found, it is possible that the profile has been anonymized (purged) or merged with another profile. To resolve this, the candidate can create a new profile using the email address. In case there is a duplicate profile, it can be merged with the most recent one.

Manage duplicate candidates_Primary email.png

Keywords

Primary E-mail, Forgot Your Password, reset, password, external candidate , KBA , reset password , password reset email , LOD-SF-RCM , Recruiting Management , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem

Product

SAP SuccessFactors Recruiting all versions