SAP Knowledge Base Article - Public

2601908 - Candidate does not receive the forgot password e-mail notification from the career site - Recruiting Management

Symptom

Candidate does not receive a password reset email when trying to log in to their candidate profile

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Candidate accesses the career site but is unable to log into their profile
  2. Candidate clicks on 'Forgot Password' link and enters their email address
  3. No e-mail is received by the candidate

forgot password.png

Cause

The candidate had two candidate profiles in the system that were merged by the company admin, leading to confusion over their correct User System ID.
or
The candidate simply changed their contact email and attempts to use this new email in the reset password box.

Resolution

How to submit the password reset request

The candidate should enter their User System ID into the Forgot Password section. The forgot password notification will then be sent to the candidate's contact email.

If the customer has the option "Use email as external applicant user ID" configured in provisioning, this will be the email address the candidate used when creating their profile.

This is the "Primary Email" which will never change, not necessarily their "Contact Email" address which can be changed at any time.

(For more information, see KBA 2157574 - Primary Email Address Versus Contact Email Address - Recruiting Management.)

How can we find the Primary Email (User System ID) information

The Primary Email (User System ID) is displayed on the Candidate Profile page if defined.

(For more information, see KBA 2676324 - The primaryEmail Field Within the Candidate Profile - Recruiting Management.)

Admins can use the tool 'Manage Duplicate Candidates' to check the information.

  1. Go to Admin Center > Manage Duplicate Candidates > Manually Merge Duplicate Candidates tab
  2. Select 'External Candidate'
  3. Select 'Contact Email'
  4. Type the email address and search
  5. Check the Primary Email

Note: After resetting the password successfully, the candidate needs to sign in using the Primary Email.

Manage duplicate candidates_Primary email.png

See Also

2296636 - Email Notification Not Received by Candidate - Recruiting Management

Keywords

Primary E-mail, Forgot Your Password, reset, password, external candidate , KBA , reset password , password reset email , LOD-SF-RCM , Recruiting Management , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem

Product

SAP SuccessFactors Recruiting all versions