Symptom
After installing Analysis for Office (AO) add-in, the SAP "Check Workstation Wizard" fails the installation check with errors regarding the EPM Add-in components
You will see the message "Workstation check has detected (x) error(s) in the installation of SAP products on this computer"
Clicking on "Error Report" to see the details will return a list of errors. This may vary depending on your computer, but generally will be of type "Error: COM Server registration paths do not match" and will refer to FPMXlClient.dll and FPMXLClient.OlapUtilities.dll.
You may also see error "Component SAP COF EPM TLB Generation and Registration is in error. It has not been successfully installed".
Installing the EPM Add-in seperately does not result in this error.
It does not matter if the installation is done via a FrontEnd Installaton server or manually via the EXE.
Environment
Analysis for Office, all versions
Reproducing the Issue
Install the Analysis for Office Excel add-on via either the SAP FrontEnd Installation or via the EXE file.
Cause
There is an error in the registration check of certain EPM related files.
These errors are purely in the wizard check code and do not impact the proper operation of the add-in in any way
Resolution
These errors may be resolved in a future release of the Analysis for Office Add-on or the SAP Logon front-end.
In the meanwhile, these errors can be safely ignored.
Keywords
KBA , EPM-XLS , EPM Excel Client , Problem