Symptom
You are trying to create a new lead with the use an existing account flag unckeched but the message "Please select a territory. Owner is assigned to multiple territories" is presented onscreen.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
-
Login in the system.
- Open the Sales work center.
- Select the Leads view.
- Click in the new button.
- Click in the Use Existing Account flag to uncheck it (in RUI it will show as NO).
- Fill in mandatory fields and try to save the lead.
You notice the warning message "Please select a territory. Owner is assigned to multiple territories"; you do not understand it since there is no account defined for this lead creation.
Cause
The fields Sales Territory ID and Sales Territory Name are by default hidden in the layout.
Resolution
This is the system standard behavior. In order to this warning message make sense, you can add the fields 'Sales Territory ID' and 'Sales Territory Name' to the lead quick creation even for the case where no existing account is defined. To do so, please follow the steps below:
-
Login in the system.
- Go to the Sales work center.
- Select the Leads view.
- Click in Adapt OR Personalize button in the upper bar.
- Select Edit Master Layout/Start Personalization.
- Click in the New button.
- Make sure that the Use Existing Account checkbox is unchecked.
- Hover the mouse cursor over a field in the Lead Creation pop-up.
- Click in the Plus icon.
- Check the select checkboxes for the fields Sales Territory ID and Sales Territory Name.
- Click in the Adapt/Personalize button in the upper bar (based on your choice of step 4).
- Select End Personalization/End Layout Changes.
Now you will be able to see the fields that the warning message is addressing, even for the scenario where no existing account is selected.
Keywords
Lead Use Existing Account Warning Message , KBA , LOD-CRM-LM , Lead Management , How To