Symptom
You created a KUT field but when you log in into the system choosing another language, this field appears blank.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
This KUT field can be in any work center in the system. The following work center and view is just an example:
- Log in into the system in your Target Language.
- Go to the Administration work centre
- Go to the General Settings view.
- Click on Language Adaptation.
- Click New.
- Write an ID and a name for this language adaptation.
- Select the source language in which you created the KUT field and another language as the target language (where the field is not translated).
- Click Save and Open.
- Search for the Sales work centre.
- Click Collect texts.
- Go to the UI Texts tab.
- Search your KUT field
- Write a Target text.
- Click Actions > Simulate Translation.
Result: The field still appears blank.
Cause
KUT fields need to have a translation inside the field properties.
Resolution
- Log in the system in your target language.
- Go to the Sales work centre.
- Go to the Opportunity view.
- Click on Adapt > Edit Master Layout.
- Hover over the ABC field (being ABC the name of the KUT field).
- Click on Change Properties.
- Click on Field Definition.
Result: You will see that there isn't any translation maintained for your target language.
Action: Enter the translation here.
Keywords
languague adaptation, translation, key user tool field, kut, field definition, change properties, blank, , KBA , AP-RC-TXA , C4C Text Adaptation , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions