Symptom
When trying to reply to a Ticket, the system displays the following Error:
'Length of subject exceeded allowed number of characters.'
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
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Go to the Service work center.
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Select the Tickets view.
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Select Ticket ABC (ABC represents the Ticket ID).
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Select the Reply hyperlink.
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Maintain a Text in the Text field.
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Select the Send button.
The following Error message is displayed and the E-Mail cannot be sent:
'Length of subject exceeded allowed number of characters.'
Cause
The limit of characters for the Subject field in a Ticket is 255. Since the incoming E-Mail was received in the Cloud for Customer tenant, this limit was not exceeded in the incoming E-Mail.
When replying to a Ticket, the text RE: [ Ticket: ABC ] is added to the subject, which triggers the error, if the Subject is exceeding the limit of 255 characters.
Resolution
In order to send out the Reply, you can edit the Subject manually.
Keywords
Error Subject E-Mail Email Exceed character limit , KBA , title length can´t exceed 128 characters , LOD-CRM-SRP , Service Request Processing , Problem