Symptom
You cannot edit the main Contact of an Account even though you have unrestricted Read and Write access for Contacts.
Environment
SAP Hybris Cloud for Customer.
Reproducing the Issue
-
Go to the Customers work center.
- Go to the Accounts view.
- Open an Account ID.
- Go to the Contacts tab.
- Select the Edit button.
- Try and edit the Contact.
- Error messages triggered:
'Save Failed'
'You are not authorized to change data'
Cause
This is the expected system behaviour.
Resolution
You have No Write Access for Accounts. Even though the user has unrestricted Read and Write access for Contacts, you still do not have authorization to edit any Contact in an Account.
Keywords
Accounts, Read and Write access, Contacts, Edit, Save Failed, You are not authorized to change data , KBA , accounts , read and write access , contacts , edit , save failed , you are not authorized to change data , LOD-CRM-ACC , Account , Problem