Symptom
You created a mandatory Z party for tickets and when you delete the involved party no warning message is being displayed.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
Prerequisite: You created Z party role Service Sales Employee for Tickets and set it as mandatory.
- Go to the Service work center.
- Go to the Tickets view.
- Open a ticket.
- Go to the Involved Parties facet.
- Delete the maintained Service Sales Employee.
- The following message is displayed: ‘Your entries have been saved’.
Cause
The ticket does not have an Account (which is mandatory and delivered by SAP).
The Account role needs to be maintained for the warning messages from other Z parties to appear.
Resolution
- Go to the Service work center.
- Go to the Tickets view.
- Open the ticket.
- Go to the Involved Parties facet.
- Add an Account and save the changes.
- Delete the Service Sales Employee.
- You see the warning message: ‘Please enter a party with role Service Sales Employee.’
Keywords
Tickets, Involved Parties, Mandatory, Z party , KBA , z party , tickets , involved party , mandatory party , LOD-CRM-SRP , Service Request Processing , How To
Product
SAP Cloud for Customer add-ins 1802 ; SAP Cloud for Customer core applications 1711 ; SAP Cloud for Customer core applications 1802 ; SAP Hybris Cloud for Customer add-ins 1711