Symptom
When running a list report the report does not return any data or is missing data.
Environment
SuccessFactors
Classic Reporting
List Reports
Reproducing the Issue
- Log into the instance
- Proxy onto the user facing the issue
- Set the respective filters
- Export to Excel
- Report output missing all data or parts of the data
Cause
This is caused in most cases due to the Date Range being set incorrectly.
The date range should not start or end on the same day that the forms start or end.
The form launch and completion would have a timestamp as information as well - which the date range does not.
Thus if you set the filter to the same day of a form being launched you will exclude the respective form from the report result.
Resolution
Adjust the date range to -1 from your respective start date.
Adjust the date range to +1 for the end date of a form.
Example:
Your forms have the following start and end dates: 01.04.2017 31.03.2018
For the above example you need to set the date range filter to 31.03.2017 and 01.04.2018 to ensure you don't exlude any results.
Keywords
List Report, Classic Reporting, Missing Data , KBA , LOD-SF-ANA-VIE , List View, Spreadsheet & Classic reports , Problem