Symptom
Workflow Rule is created to get triggered on Every Save of Business Object - Opportunity. For certain reasons, workflow failure notification is received with an error message - Locking Object not possible, object locked by *
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to Sales Work Center
- Then to Opportunity View
- Open Opportunity ABC, where, ABC is any Opportunity
- Do any changes and save it, in order to trigger the Workflow Rule created - On Every Save
- A notification regarding workflow failure will be received with an error mesasge - Locking Object not possible, object locked by *
Cause
Creating an Activity referencing Parent Business Object, triggers a Business Transaction Document( BTD). The reference gets created which will trigger workflow rule. This could be tracked in workflow monitoring log.
-
Open Opportunity instance ABC
-
Click on Edit button
-
Create any Activity, say, Tasks, Emails, Tasks,.
-
A Business Transaction Document (BTD) reference gets created which will trigger workflow rule
-
This could be seen on workflow monitoring log.
-
It could be seen that execution of workflow rule will get failed with reason "Locking Object not possible, object locked by *".
Resolution
When creating any activity referencing another business object, make sure that parent object should not be in "EDIT" mode.
Keywords
Locking Object not possible, object locked by * , Workflow,Notification, Error , KBA , LOD-CRM-WKF , Workflow , How To