SAP Knowledge Base Article - Public

2606514 - Workflow Failure with Error Message - Locking Object not possible, object locked by *

Symptom

Workflow Rule is created to get triggered on Every Save of Business Object -  Opportunity. For certain reasons, workflow failure notification is received with an error message - Locking Object not possible, object locked by *

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Sales Work Center
  2. Then to Opportunity View
  3. Open  Opportunity ABC, where, ABC is any Opportunity
  4. Do any changes and save it, in order to trigger the Workflow Rule created - On Every Save
  5. A notification regarding workflow failure will be received with an error mesasge - Locking Object not possible, object locked by *

Cause

Creating an Activity  referencing Parent Business Object, triggers a Business Transaction Document( BTD). The reference gets created which will trigger workflow rule. This could be tracked in workflow monitoring log.

  1. Open Opportunity instance ABC
  2. Click on Edit button
  3. Create any Activity, say, Tasks, Emails, Tasks,.
  4. A Business Transaction Document (BTD) reference gets created which will trigger workflow rule
  5. This could be seen on workflow monitoring log.
  6. It could be seen that execution of workflow rule will get failed with reason "Locking Object not possible, object locked by *".

Resolution


When creating any activity referencing another business object, make sure that parent object should not be in "EDIT" mode.

Keywords

Locking Object not possible, object locked by * , Workflow,Notification, Error , KBA , LOD-CRM-WKF , Workflow , How To

Product

SAP Cloud for Customer core applications all versions