Symptom
When creating a new Ticket manually or changing the Account / Individual Customer of an existing Ticket, the following Warning is displayed:
'Ticket document language changed.'
Environment
SAP Cloud for Customer
Reproducing the Issue
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Go to the Service work center.
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Select the Tickets view.
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Click the New button to create a Ticket.
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Maintain Account ABC ( ABC represents the Account ID).
The following Warning message is displayed: 'Ticket document language changed.'
Cause
In the 1802 Release, the field Document Language was added to the Additional Information Section in a Ticket.
The document language is determined automatically based on the customer information. If there is a change made to the customer details, this message is shown, since the language is re-determined.
Resolution
This is the expected system behaviour. This standard message cannot be hidden or removed.
In case you would like to change the existing behavior please post your request in the Influence page; there you can request the new features for the new releases of the system. This channel also allows you to follow up your requests directly with the C4C Product Management Team
https://influence.sap.com/sap/ino/#/campaign/1867
Posting it there is a must, since such requests are not handled via standard Support Channel. Any changes to the existing system might impact the existing customers and user experience in different ways. Our PM team can check the requests, validate any side effects and then consider it via the Influence Page.
See Also
Keywords
Warning, Ticket, Individual Customer, Account, change Language document, Language , KBA , LOD-CRM-SRP , Service Request Processing , How To