Symptom
- Succession Data Model sync corrupts target instance.
- "Manage Business Configuration" tool shows error in target instance after sync.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Go to Admin Center > Instacence Synchronization Wizard.
- Run a Succession Data Model sync (using Instance Sync Tool) from a BizX instance where the data model includes custom objects that are not present in the target instance. (KBA on Instance Sync Tool and how to use it -> 2088055).
- The sync will be successful but, subsequently, the target instance will have problems.
For example: The "Manage Business Configuration" tool will fail to load and show Java error on screen.
Cause
The data model that has been synced includes custom objects that do not exist in target instance.
Resolution
The following steps will ensure that the data model is properly synced from source to target instance.
- Download the succession data model from the source instance using provisioning "Import/Export data model".
- Identify the custom objects that are mapped in the succession data model.
- In the source instance, navigate to Instance sync wizard and select "MDF Object definition" as the artifact to sync and then proceed next by providing sync name and description.
- In the Copy Object Definition page, select the custom object definitions identified in step 2 and perform the sync. The sync should get completed successfully.
- You can then proceed with the sync of data model. This should also be successful now.
See Also
Keywords
Sync Instance Sync Data Model SDM Custom Objects , KBA , LOD-SF-PLT-IST , Instance Sync Tool , Problem
Product
SAP SuccessFactors HCM Suite all versions