SAP Knowledge Base Article - Public

2607148 - Cancellation Email Sent to Manage /Approver When Editing Time Off Request Before Approval - EC

Symptom

When an employee submits a time off request and edits the request before the corresponding workflow is approved, a cancellation e-mail notification is triggered to the manager (or the workflow step approver).

Environment

  • SAP SuccessFactors HXM Suite
  • SAP SuccessFactors Employee Central
  • Time Off

Reproducing the Issue

  1. Navigate to Time off
  2. Under 'My Requests' click on 'edit' of an existing Time Off Request that has not yet been approved
  3. Edit the start / end date of the request and click submit
  4. Two e-mail notifications are sent to the manager (or the workflow step approver), one email informing them of the correction that was made and another notification informing them that the orignal request has been cancelled

Cause

This is expected system behaviour

Resolution

  • Currently in Flight Edits are not supported for Time Off workflows
  • The workflow must be completed before you make any changes via Manage Time Off UI
  • If you'd like to see this functionality changed in a future release, please create a SAP SuccessFactors Enhancement Request

See Also

KB article 2090228 - How to Submit Enhancement Requests for SAP SuccessFactors Products

Keywords

SF, Success Factors, cancelled, EC, e-mail, timeoff, work flow , KBA , xaf-10612 , ect-60347 , LOD-SF-EC-TIM , Time Off , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions