SAP Knowledge Base Article - Public

2607638 - In Action Search, 'Update Personal Information for' Displays Twice When Searched for

Symptom

When searching in Action Search for the function 'Update Personal Information for...', 2 results both saying 'Update Personal Information for...' appear

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

  • Employee Central
  • Action Search
  • Personal Information

Reproducing the Issue

1. Navigate to the Home Page of a user

2. In the 'Action Search' bar, type 'Update Personal Information for...'

3. 'Update Personal Information for...' displays twice
Update_personal.png

Image_from_demo_system.png

Cause

Both of these links will bring you to different sections of the user's Personal Information.

When selecting for a user;

1. The first link directs you to the edit section of the Personal Information portlet of the user
Link1.png

Image_from_demo_system.png

2. The second link directs you to the Personal Information on the user's Employee Profile
Link 2.png

Image_from_demo_system.png

Resolution

This is default system behaviour. When the system performs the search, the action 'UPDATE_PERSONAL_INFORMATION' checks features 'Employee Central V2' and 'People Profile', so when both of features are active, both actions will appear in the result.

There is an ongoing communication with Engineering and Product Management to see if these 2 actions can be labelled differently

Keywords

Update Personal Information for, Duplicate, Twice, Personal Information, Update, ECT-92808, Action Search , KBA , LOD-SF-EC-PER , Person Data (All Person Data Types) , Problem

Product

SAP SuccessFactors Employee Central 1611 ; SAP SuccessFactors Employee Central 1702 ; SAP SuccessFactors Employee Central 1705 ; SAP SuccessFactors Employee Central 1708 ; SAP SuccessFactors Employee Central 1711 ; SAP SuccessFactors Employee Central 1802