Symptom
You have a problem when choosing the Replication Target System in the SFSF preview you see the below
Error:
"An application error occurred. Please try again later, or notify support (with the error information of errorId=XXXXX-XXXX-XX-XXX-XXXXX, timestamp=20XX-02-XXT19:22:47.234+0000, and the version information from the current screen) if the issue keeps occurring."
Environment
Successfactors
Reproducing the Issue
Please provide step-by-step instructions on how to reproduce your issue:
Step 1: Go to Data Replication Monitor
Step 2: Try to select the Replication Target System
Step 3: A pop up window shows up with error message:
"An application error occurred. Please try again later, or notify support (with the error information of errorId=XXXXX-XXXX-XX-XXX-XXXXX, timestamp=20XX-02-XXT19:22:47.234+0000, and the version information from the current screen) if the issue keeps occurring."
Cause
It seems that the problem is connected to RBP on the ReplicationTarget filter.
The permission check tries to get the default name of the Replication Target System object. Unfortunately it checks the localized name of en_US as default name, which seems not to be configured.
Resolution
Workaround:
As a workaround you can import the Replication Target Systems as a csv file, containing the externalName for en_US. Please follow the steps below:
- Go to Admin Center -> Import and Export Data
- Select "Export"
- Select "Replication Target System" as Generic Object
- Click "Export" Button
- Go to Admin Center -> Monitor Job
- Download export file as soon as job has finished by clicking "Export Status" Link
- Open csv file containing the Replication Target Systems
- In the first row, which contains the column names, add new column "externalName.en_US"
- For each row and Replication Target System, copy the respective externalName and add it to the row (to the position, as it is implied by the new column "externalName.en_US" at the very first row with column names)
- Save the file
- Go to Admin Center -> Import and Export Data
- Select "Import"
- Select "CSV File" as file format
- Select "Replication Target System" as Generic Object
- Upload edited file
- Click "Import" Button
- When the import job has finished, go to Data Replication Monitor and try to reproduce the application error
This is fixed in b1805 release
Keywords
ECT-91814, Replication Target System, 1805, Data Replication Monitor , KBA , LOD-SF-INT-DRM , Data Replication Monitor , LOD-SF-INT , Integrations , Problem