Symptom
When trying to send an outbound E-Mail from a Ticket, the following error is displayed:
'Please use not more than 1 party(ies) of role Contact.'
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
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Go to the Service work center.
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Select the Tickets view.
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Open Ticket ABC (ABC represents the Ticket ID).
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Select the Compose New E-Mail hyperlink.
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Maintain a text in the E-Mail body.
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Select the Send button.
The following error message is displayed:
'Please use not more than 1 party(ies) of role Contact.'
Cause
The party determination when the Email Activity is created was improved in 1802.
The error that is coming up on the UI is showing the data inconsistency present in the system.
This is happening because there is a Contact in the system, which has the E-Mail address of the E-Mail Channel maintained.
Ideally, this is supposed to be just a channel ID, which in turn will be present in one dummy customer.
There should not be any contact with the same E-mail ID.
The Sender is passed for the E-Mail activity creation with the corresponding E-Mail address. This is resulting in the determination of multiple contacts as there are multiple contacts with the respective E-Mail ID's.
Resolution
The E-Mail address that is maintained in the E-Mail channel needs to be removed from the Contact.
Keywords
Ticket Outbound Outgoing E-Mail Send Error Party Contact multiple , KBA , LOD-CRM-SRP , Service Request Processing , Problem