SAP Knowledge Base Article - Public

2610523 - Creating Survey Report for Partner Survey Answers

Symptom

You want to have a report with the answers from partner surveys and for that you have used the Standard Report Business Partner Survey: Customer Satisfaction Answers [QREVQVBUPARJ_Q0001]. However, even with all correct Access Context, you and all employees are not able to see the Data From this Report.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the Business Analytics.
  2. Find the report: Business Partner Survey: Customer Satisfaction Answers.
  3. Enter the parameters in the expected fields and select Go.
  4. An error is displayed 'No Data Available for this User. Check the Selections'.

Cause

Business Partner Survey: Customer Satisfaction Answers [QREVQVBUPARJ_Q0001], There is global restriction (in Data Source Level) as per which the logged in user will be able to see the responses of only those surveys which are responded by the customers( & contacts) for which he is responsible for or related to.
The respondent of the survey should be related to the logged in business user means that:

  1. Either the logged in user should be the responsible agent of the respondent.
  2. Other employees belonging to the same sales unit who have the same position as the logged in user, should be the responsible agent of the respondent.
  3. Or functional unit managers, who belong to the logged in users subordinate sales units, should be the responsible agent of the respondent.

If there is no customer for which this particular employee is maintained as the responsible agent, then this employee (the user who is trying to check the information) will not be able to view the report data.

Resolution

You have two options:

Option 1 - You should maintain the employee responsible data correctly for their business partners, for all of them and for all employees you have to ensure to have this enable in their profile as well.

Option 2- If you do not want to have any restrictions like this, you simply can create your own report from the data source. This new report will be generated without any restriction, then all the employees will be able to see the report data or you can also have their own way of maintaining the restrictions. For this, please follow the steps below to create a new report based in the available Data Source:

  1. Go to the Business Analytics Work Center.
  2. Select the Data Sources sub menu option.
  3. Search for Business Partner Survey Answers.
  4. Create a new Report, and select the characteristics and Key Figures you want to have.
  5. Click on Finish when you have choose all options.
  6. Open the report created, note it will be already possible to see the data from the surveys.

Warning: Do not create a copy of the standard report: Business Partner Survey: Customer Satisfaction Answers, it will use the very same Data Source, which have the restrictions applied on it, hence a report created as copy will also have the same behavior as the standard. Create it from the Data Source you can find on Business Analytics, Business Partner Survey Answers.

Keywords

Create Survey report, Report does not show data, Survey report , KBA , LOD-LE-SUR-ANA , Survey Analytics , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions