Symptom
The "Ask for Feedback" email has been replied, however, in the supporting pod, as in the Team overview, the reply is empty, only shows the date and name of the person who replied:
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Performance Management
Reproducing the Issue
- The msg key PERFORMANCE_FEEDBACK_EMAIL_BODY_PREFIX has been left blank because the standard text for this has been added in the email template:
- The "Ask for Feedback" email will be shown as below, in which the highlighted space is where the PERFORMANCE_FEEDBACK_EMAIL_BODY_PREFIX appear in the standard language pack, as it has been customized to be blank, only the "~~~~~~" sign appear as this is hardcoded in the system:
- With the msg Key configured this way, the feedback text will not be visible in the supporting pod nor in the Team overview, only the name of the feedback provider and the date:
Cause
By using the msg Key PERFORMANCE_FEEDBACK_EMAIL_BODY_PREFIX without any value, will cause a validation error in the system and the behavior as mentioned above.
Resolution
To avoid this scenario, you can add any text or value desired for the PERFORMANCE_FEEDBACK_EMAIL_BODY_PREFIX msg key, it is important to not leave it empty.
Please refer to the example below:
- Text added "Click on reply and enter your text to add feedback":
- The text added for the key will be shown as in the email below:
- The Feedback information will be recorded accordingly into the system:
See Also
Keywords
Ask Feedback; Feedback; Empty Feedback; Manage Languages , KBA , LOD-SF-PM-FBK , Feedback: Get Feedback, Ask for Feedback, etc. , How To