Symptom
For an object in your system you want to change the Territory but when you type into the territory field, the system does not suggest any value.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
This can happen in different screens, in our example we will use the Territory Ireland within the Service Ticket view as an example.
Prerequisite: You have Territory management active and set up within your system.
-
Go to the Service work center.
- Go to the Tickets view.
- Open any In Process or Open Ticket ABC (ABC represents the ticket name/ID - the same will not work for completed tickets!).
- Click Edit.
- In the Header, click into the Territory field.
- Delete the existing value.
- Type a different value, example, existing value is Germany and you now want to type Ireland. You start by typing IRE with the expectation that the system suggests the full value.
- Result: The system does not suggest any value.
Cause
Your ticket ABC's customer does not have the territory IRELAND maintained and or the ticket's employee does not have that territory assigned.
The OVS is context based and will show only the territories belonging to the employee. Further, the default set (the query which is triggered by default) is Related Territories and hence would show the search results only if there is any territory that matches the account of the ticket, meaning the territory checks for the account's territory.
Resolution
You can select the query All and then search for the needed territory. Or you can enhance your territory assignment for customers.
-
Repeat steps 1- 5.
- Click on the OVS (value search button).
- Change the search to All Territories.
- Select the needed territory.
- Save.
See Also
Administration Guide: Activating Territory Management (+ related documents).
Keywords
Activating Territory Management, Territory, Change, Ticket, Related Territories, , KBA , LOD-CRM-TM , Territory Management , How To