SAP Knowledge Base Article - Public

2610897 - Custom Workflow Notifications - Custom Placeholder Field Value Not Appearing in Notification Email

Symptom

Custom Placeholder field value is not appearing in Custom Workflow Notification

Environment

  • SAP SuccessFactors HCM Core
  • Employee Central
  • Manage Document Template Mapping

Reproducing the Issue

  1.  Create a document generation group.
  2.  Define an email template and assign the document generation group.
  3.  Define the mapping for your placeholder.
  4.  Create a workflow email configuration.
  5.  Assign the workflow email configuration at the workflow configuration step level.
  6.  Trigger Workflow
  7.  Value that should be returned by the placeholder mapped in step 3 is blank in the notification.

Cause

This occurs if the value the placeholder is trying to return is being set by an onInit or onView rule.

Resolution

  • As any value being set by onInit or onView rules does not exist within the database, it cannot be queried and so cannot be returned.
  • Therefore the only resolution is to change configuration so that an actual value is set in the field in use by the placeholder.

Keywords

SF, success factors, EC, blank field value, placeholder, missing value, no data , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC , Employee Central , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Core all versions